quectel modem type doesn't configure properly on RB5 5G drone with Voxl SDK image



  • Using Qualcomm RB5 5G Drone with VOXL SDK drone image from 07/22

    I am trying to connect a Qualcomm RB5 5G drone to a 5G SA network and the "correct" option of quectel in the voxl-configure-modem does not seem to be working correctly. When choosing quectel, the voxl-modem service gets stuck on "Initializing Cellular Connection", or more specifically "quectel-CM -s <myapn>". Restarting the service and drone does not help. Strangely, when I just choose V2 as my modem type I have not issues connecting. Upon drone reboot, however, the v2 configuration needs to be redone in order to connect properly somehow. Very strange and unstable.

    When using the quectel config, our basestation shows that the drone doesn't send out the request for an IP at ever.

    In the past, the quectel config would work, but I don't know the hacky process I went through in order to get it "working".


  • Dev Team

    @Sam-Kiley The old RB5 system image / sdk was also using “quectel-CM” in order to establish a connection to the network. Just to confirm, you are using an M0090 with Quectel modem? Do you have any other network connections that may be interfering (WiFi, Ethernet, Microhard, etc.)?



  • 0e6cbb24-ed41-43d9-b435-8f6383e8e385-image.png

    I am using this flight image 1.3.1-0.8 with Voxl SDK. And I just found the "quectel-CM" command by looking into the voxl-modem src on git.

    there is not Ethernet connected and the wpa_supplicant file has "blank" set for ssid and password to disable it.

    Honestly, I have been having trouble understanding the versions of the RB5 drone, so how would I check if its definitely M0090? Its the Qualcomm Flight RB5 5G Platform Drone Reference Design


  • Dev Team

    @Sam-Kiley If you're using the RB5 drone then yes it comes with an M0090 + Quectel modem if you purchased the 5G option. So if you haven't torn it apart then you've got the correct hardware.

    If you disable the voxl-modem startup service with systemctl disable voxl-modem and systemctl stop voxl-modem and then run the quectel connection manager on it's own:
    quectel-CM -s $YOUR_APN what does the output look like?



  • quectel-CM -s wirelessone.com
    [10-21_21:03:16:465] Quectel_QConnectManager_Linux_V1.5.9
    [10-21_21:03:16:467] Find /sys/bus/usb/devices/2-1.1 idVendor=0x2c7c idProduct=0x800, bus=0x002, dev=0x003
    [10-21_21:03:16:467] Auto find qmichannel = /dev/cdc-wdm0
    [10-21_21:03:16:467] Auto find usbnet_adapter = wwan0
    [10-21_21:03:16:467] netcard driver = qmi_wwan, driver version = 22-Aug-2005
    [10-21_21:03:16:467] Modem works in QMI mode
    [10-21_21:03:16:486] cdc_wdm_fd = 7
    [10-21_21:03:16:561] Get clientWDS = 2
    [10-21_21:03:16:593] Get clientDMS = 1
    [10-21_21:03:16:619] Get clientNAS = 4
    [10-21_21:03:16:651] Get clientUIM = 1
    [10-21_21:03:16:683] Get clientWDA = 1
    [10-21_21:03:16:715] requestBaseBandVersion RM502QAEAAR11A02M4G
    [10-21_21:03:16:849] requestGetSIMStatus SIMStatus: SIM_READY
    [10-21_21:03:16:849] requestSetProfile[1] wirelessone.com///0
    [10-21_21:03:16:913] requestGetProfile[1] wirelessone.com///0
    [10-21_21:03:16:944] requestRegistrationState2 MCC: 0, MNC: 0, PS: Detached, DataCap: 5G_SA
    [10-21_21:03:16:977] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
    [10-21_21:03:16:977] ifconfig wwan0 down
    [10-21_21:03:17:000] ifconfig wwan0 0.0.0.0
    


  • Also, we have just ran into the same issue, but this time with anther drone of same model, but instead with the RB5 SDK image on it. So when using rb5-modem-configure and choosing quectel, the modem does not connect to t-mobile (the sim we currently have on it). We did have a 5G SA sim on it before and disconnecting from the private network must have caused some wires to get crossed with quectel. Is there a way to reset any important files/services related to quectel more specifically?


  • Dev Team

    @Sam-Kiley The only time we ever write to the modem itself is when setting the mode_pref via. an AT command: https://gitlab.com/voxl-public/voxl-sdk/utilities/voxl-modem/-/blob/master/scripts/voxl-modem-start.sh#L45

    echo -ne "AT+QNWPREFCFG=\"mode_pref\",LTE:NR5G\r" | busybox microcom -t 1000 /dev/ttyUSB2
    

    You can request the AT command docs for the Quectel module from Quectel themselves as there are hundreds of AT commands that can be used for different settings.



  • Yes, I believe I found that AT command doc in another forum thread. I can take a look. Do you see anything out of ordinary in quectel-CM in the above? There are also other command options for voxl-modem that seem useful, but not sure about if they are helpful for my situation or not.


  • Dev Team

    @Sam-Kiley I dug into this a bit and was having intermittent issues on my side as well. In voxl-modem I updated the quectel-CM source after pulling a newer version and things are working now on my side.

    Can you try out this voxl-modem dev package and see if it works for you?
    http://voxl-packages.modalai.com/dists/qrb5165/dev/binary-arm64/voxl-modem_0.16.2-202210261800_arm64.deb

    Do the following to install this updated package:

    adb push voxl-modem_0.16.2-202210261800_arm64.deb .
    
    adb shell
    
    dpkg -i voxl-modem_0.16.2-202210261800_arm64.deb
    


  • That fixed the instability issues! Thanks!


  • Dev Team

    @Sam-Kiley Awesome! Let me know if anything changes.



  • Are you able to provide the source for that new version of Quectel-CM or it is just pulled form here? https://github.com/kmilo17pet/quectel-cm

    Would like the source ourselves for another program we are running that interfaces with the quectel modem.


  • Dev Team

    @Sam-Kiley All of the VOXL suite is open source, voxl-modem lives here: https://gitlab.com/voxl-public/voxl-sdk/utilities/voxl-modem/-/tree/dev

    The quectel related source is from https://gitlab.com/voxl-public/voxl-sdk/utilities/voxl-modem/-/tree/dev/src/quectel-CM

    But yes I believe that’s where I get the updated version from. I’ve also reached out to Quectel to make sure I get the very latest.


Log in to reply