Can't connect to QGroundControl over wifi...



  • Hello I've tried all three different ways to connect to the internet but none of the ways allows me to connect to QGround without wire connection. I can ADB and wire connect but WIFI doesn't work. I had it working for just a little while but it doesn't want to connect anymore. I have updated the firmware to 1.13 from QGround via wire and uploaded the Parameters from the GitHub page. I would appreciate some guidance. Thank You.


  • Dev Team

    With the wired connection to QGC, can you run go to the MAVLink shell and run the following?

    mavlink status

    There should be a TELEM2 instance setup with baud 921600 to match that of VOXL-Flight.

    TEL2 (/dev/ttyS4, or UART5), maps to J1 on Flight Core, and internally routed in VOXL-Flight.

    Ensure these are setup, otherwise voxl-vision-px4 won't talk with Flight Core portion of the circuit.

    MAV_1_CONFIG 102
    MAV_1_FORWARD 0
    MAV_1_MODE 2
    MAV_1_RATE 0
    SER_TEL2_BAUD 921600

    On the VOXL side, you can adb in, and run these command line:
    voxl-vision-px4 and voxl-mavlink-server in order to see status.



  • @modaltb said in Can't connect to QGroundControl over wifi...:

    mavlink status

    mavlink_status.PNG
    Here is the print out of the mavlink status, I see there is /dev/ttyS4 at 921600 baud rate. Is this what we need?
    I've checked the MAV and Serial configuration they are the same as you have provided.
    MAV_configuration.PNG
    The connection to QGroundControl via Wi-Fi still doesn't want to connect.
    VOXL-VISION-PX4 printout:
    Screenshot from 2022-10-20 22-55-09.png
    Also, the Wi-Fi doesn't work anymore as well.... there is no WLAN0 showing up on VOXL anymore.
    Screenshot from 2022-10-20 23-06-04.png
    Sorry for the late reply, Ill be checking in more frequently now. I really need help setting this up so I can continue my thesis. Thank you for your help.


  • Dev Team

    If wlan0 isn't showing up, then the system isn't seeing the Wi-Fi hardware. I think I saw another forum topic around this as well, it seems to be possible HW/system image corruption perhaps? Without the wlan0 interface there's no WiFi to be had on VOXL1.



  • @modaltb
    What do you suggest I should do then?
    Do I need to flash the board? Or take it down a version?


Log in to reply