Microhard MDK-M0048-2 to Android

  • I am having some trouble getting my Android devices to recognize the modem carrier. Can you provide guidance on connecting the standalone carrier to an Android host? The device works fine with Windows/Linux PC over USB.

    Based on the documentation stating that the carrier added the LAN7500 controller for Android compatibility, I thought my device would recognize it. I contacted Microhard, and they were surprised it worked with Android at all... I know it must be possible since the Voxl is android at its core. Any pointers would be great so I can decide if it is even worth trying, or if I need to completely change approach. USB to RJ45 adapter is working with the phone, worst case I could try to connect directly to the ethernet port on the modem.

    From the documentation, https://docs.modalai.com/microhard-usb-carrier/, USB DN1 and DN2 are both connected to the modem. I assume DN2 is responsible for the network connection, right? Just trying to collect information for USB enumeration/troubleshooting. I've noticed that sometimes the device shows up as NULL on Android, and sometimes as pmDDLxxx. I haven't been able to consistently determine what causes the state change.

  • Dev Team

    @tangotoo It depends on what kind of Android device you're using. Not all android hardware / builds support the same LAN chips.

  • @tom I've tried it on an S21 and Pixel 4 phones and haven't had any luck. If its a non-starter, that would be good to know so I can focus my efforts on a different solution versus trying to force the phones to cooperate. FWIW, I can flash/modify/sideload whatever is required to make it happen.

    The objective is to bring up QGC on the device with the GCS link via uHard.

  • Its working on a different android device, so I think its a kernel module issue on the S21. We can close this out.

  • Dev Team

    @tangotoo Awesome, thanks for the feedback.

Log in to reply