Mavproxy OK when Vision is not needed?



  • I am currently using Ardupilot on my flight core, and thought I could use the voxl-vison service for the Mavlink relay to the GCS. However, the voxl-vision service is failing as below. Is this because I don't have any cameras currently installed.

    If I only need the mavlink relay, should I install Mavproxy instead?

    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: follow_tag_id:              0
    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: figure_eight_move_home:     1
    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: en_tag_fixed_frame:         0
    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: fixed_frame_filter_len:     5
    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: en_transform_mavlink_pos_setpoints_from_fixed_frame:0
    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: =================================================================
    Jan 01 00:59:37 apq8096 voxl-vision-px4[3336]: loading extrinsics config file
    Jan 01 00:59:37 apq8096 systemd[1]: voxl-vision-px4.service: Main process exited, code=exited, status=255/n/a
    Jan 01 00:59:37 apq8096 systemd[1]: voxl-vision-px4.service: Unit entered failed state.
    Jan 01 00:59:37 apq8096 systemd[1]: voxl-vision-px4.service: Failed with result 'exit-code'.
    

  • Dev Team

    voxl-vision-px4 is the right path. I'll ping some folks and see if they have suggestions on how to debug further.



  • Thanks for the follow up. After starting down the mavproxy path it looks quite cumbersome due to needing to add multiple python modules without the benefit of pip that likely don't have build wheels for the voxl arch.

    Look forward to feedback on the voxl-vision method, I'll keep working at it.



  • OK I think the error is that I did not have an extrinsics file. I ran voxl-configure-extrinsics with the starling-voxl-flight config and that has cleared that initial error. When I run voxl-vison-px4 -d (to get uart debug) I'm not currently seeing any output. I'm going to check on my configs to verify telem2 is sending uart as needed from Ardupilot.



  • I set TELEM2 in ardupilot to 921.6K and protocol to MavLink2. On the VOXL I'm not sure that voxl-vision is running correctly. voxl-vision-px4 -d just hangs at entering main loop. After reviewing the source, it looks like I am entering the main loop/sleep but none of the threads are reporting data. I can try an image reflash if needed but I just reflashed to latest while troubleshooting microhard issues.

    Any guidance on how best to troubleshoot serial coms on VoxlFlight to verify they are operational would be great.



  • @Chad-Sweet I reflashed my flightcore to PX4 to support debug since PX4 is the supported FC firmware. Still no communication when executing voxl-vison-px4.

    Couple debug questions:
    Which tty device should be associated with UART5/TELEM2 on the VOXL? I was thinking I could use screen to check for any signs of life directly on the serial port. I'm going to try reflash of the VOXL-Flight image next. I don't really know what else to try.



  • Fresh reflash with deleted data partition of 3.8.0-0.7. Totally stock, using PX4 on FlightCore.
    Executed

    voxl-configure-extrinsics
    

    , used setting 5 for voxl-flight
    Executed

    voxl-configure-vision-px4
    systemctl stop voxl-vision-px4
    
    voxl-vision-px4 -d
    

    Still no output from telemetry, still hangs in the main loop with no threads updating.

    =================================================================
    loading extrinsics config file
    starting geometry module
    starting px4 monitor
    starting px4 mavlink
    starting udp mavlink
    Adding manual QGC IP address to udp connection list: 192.168.8.60
    Added new UDP connection to 192.168.8.60
    starting px4 shell
    starting fixed pose input
    starting vio manager
    starting tag manager
    starting voa manager
    starting control input pipe
    Init complete, entering main loop
    


  • Downgrade to 3.6.0-0.5 works. I see the message,

    '''
    PX4 Connected over UART with sysid 1
    '''
    when executing voxl-vision and QGC detects the stream. There is a bug in 3.8.0/or the procedures it appears. I upgraded because I was having issues with the microhard modem configuration in 3.6, I'll revisit that problem now. At least we can confirm there are no hardware issues, but the software issue with 3.8.0 remains.


  • Dev Team

    Hi,

    It looks like the issue is that you're not running voxl-mavlink-server which routs the mavlink packets to/from vvpx4 over uart/udp. This was broken out of vvpx4 core in voxl-suite 0.6 which explains why it was working on the old release 0.5. If you run the fresh suite 0.7 install and do what you did while also enabling mavlink server everything should behave properly.



  • @Alex-Gardner that did it! We definitely need to update the docs. I was going over all the Voxl Vision docs I could find and I don't recall seeing anything about voxl-mavlink-server.

    A flowchart might be nice, I ran into a similar issue with Voxl Camera Streamer and the camera server service, but I figured that one out thanks to the docs.


Log in to reply