"Plan to a point" not working



  • Hi,
    I am using Sentinel Drone with voxl-portal and voxl-mapper.
    We've changed voxl-mapper.conf to work with stereo camera.
    However, plan to a point is not working. When we give a point, it generates trajectory, but Sentinel doesn't move at all.
    We've changed offboard to trajectory. Is there any solution to it?
    Thanks.


  • Dev Team

    Hey @darwin-keem,

    Could you please share the output of apt list --installed | grep voxl so we can know which versions you have installed?

    Additionally, are you seeing any error messages from voxl-mapper when you try to follow the path?



  • Hi @Matt-Turi,
    output of apt list --installed | grep voxl is listed below.

    voxl2:~$ apt list --installed | grep voxl
    
    WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
    
    libvoxl-cutils/unknown,now 0.1.1 arm64 [installed,automatic]
    mv-voxl/now 0.1-r0 arm64 [installed,local]
    voxl-bind/unknown,now 0.0.1 arm64 [installed,automatic]
    voxl-camera-calibration/unknown,now 0.2.2 arm64 [installed,automatic]
    voxl-camera-server/unknown,now 1.1.0 arm64 [installed,automatic]
    voxl-ceres-solver/unknown,now 1.14.0-7 arm64 [installed,automatic]
    voxl-cpu-monitor/unknown,now 0.2.6 arm64 [installed,automatic]
    voxl-docker-support/unknown,now 1.2.4 arm64 [installed,automatic]
    voxl-jpeg-turbo/unknown,now 2.1.3-4 arm64 [installed,automatic]
    voxl-libgphoto2/unknown,now 0.0.4 arm64 [installed,automatic]
    voxl-libuvc/unknown,now 1.0.6 arm64 [installed,automatic]
    voxl-logger/unknown,now 0.3.2 arm64 [installed,automatic]
    voxl-mapper/unknown,now 0.0.7 arm64 [installed]
    voxl-mavlink/unknown,now 0.1.0 arm64 [installed,automatic]
    voxl-mavlink-server/unknown,now 0.1.3 arm64 [installed,automatic]
    voxl-modem/unknown,now 0.16.0 arm64 [installed,automatic]
    voxl-mongoose/unknown,now 7.6.0 arm64 [installed,automatic]
    voxl-mpa-to-ros/unknown,now 0.3.3 arm64 [installed,automatic]
    voxl-mpa-tools/unknown,now 0.7.2 arm64 [installed,automatic]
    voxl-nlopt/unknown,now 2.5.0-4 arm64 [installed,automatic]
    voxl-opencv/unknown,now 4.5.5-1 arm64 [installed,automatic]
    voxl-portal/unknown,now 0.2.8 arm64 [installed]
    voxl-px4/unknown,now 1.4.16 arm64 [installed,automatic]
    voxl-px4-imu-server/unknown,now 0.1.2 arm64 [installed,automatic]
    voxl-qvio-server/unknown,now 0.7.1 arm64 [installed,automatic]
    voxl-streamer/unknown,now 0.3.6 arm64 [installed,automatic]
    voxl-suite/unknown,now 0.8.1 arm64 [installed]
    voxl-tag-detector/unknown,now 0.0.4 arm64 [installed,automatic]
    voxl-tflite-server/unknown,now 0.2.7 arm64 [installed,automatic]
    voxl-utils/unknown,now 1.1.4 arm64 [installed,automatic]
    voxl-uvc-server/unknown,now 0.1.1 arm64 [installed,automatic]
    voxl-vision-px4/unknown,now 1.2.0 arm64 [installed,automatic]
    voxl-voxblox/unknown,now 1.0.4 arm64 [installed,automatic]
    voxl2-system-image/now 1.3.1-r0 arm64 [installed,local]
    voxl2-wlan/now 1.0-r0 arm64 [installed,local]
    

    We don't see any error messages from voxl-mapper.

    ERROR fetching tf from tf ringbuffer
    there wasn't sufficient data in the buffer
    

    This message shows up intermittently, but doesn't seems to effect in mapping function. Message below is the message after using Plan to a point feature.

    Client requested slice level update
    Client requested slice level update
    Client requested slice level update
    Client requested slice level update
    Client requested plan to location
    Using start pose of: x:  -0.08, y:   0.04, z:   0.02
    using goal pose of: x:  -1.04, y:   3.00, z:   0.02
    Map Bounds:
    Lower-> x: -6.40, y: -3.20, z: -3.20
    Upper-> x:  6.40, y:  6.40, z:  3.20
    Switching to 3D checks
    
    ------------------------------------------
    TIMING STATS
    ------------------------------------------
    Solve time             ->          1000.01ms
    Total time             ->          1000.04ms
    Random node grab time  -> Average:   0.00ms, TOT:  48.90ms
    Nearest node time      -> Average:   0.01ms, TOT: 508.83ms
    Check motion time      -> Average:   0.00ms, TOT: 354.81ms
    Neighborhood grab time -> Average:   0.00ms, TOT:   6.05ms
    Children update time   -> Average:    nanms, TOT:   0.00ms
    
    ------------------------------------------
    GENERAL STATS
    ------------------------------------------
    PATH LENGTH:   3.11
    ATTEMPTS: 42415
    QNEAREST FAILS: 59
    RANDOM TO NEAREST FAILS: 39915
    PARTIAL SEGMENTS ADDED: 2441
    TREE REWIRES: 0
    ------------------------------------------
    RRTSTAR FAILED: Exceeded max iterations. Outputting closest path
    Simplifying Path took:   0.07ms
    Removed 0 nodes
    Collisions along base path-> no
    No free constraints set in the vertices. Polynomial can not be optimized. Outputting fully constrained polynomial.
    Loco Smooth took: 467.29ms
    Success-> yes
    

    However, we found this error in voxl-portal. Would it be the reason of this problem? If so, how can we solve it?

    voxl2:/$ voxl-portal
    exising instance of voxl-portal found, attempting to stop it
    voxl-portal started up
    Server providing: battery connected
    Server providing: flight_info connected
    Server providing: gps connected
    Server providing: gps connected
    Server providing: flight_info connected
    Server providing: battery connected
    Server not available
    
    
    Failed to open pipe: /run/mpa/plan_msgs/
    
    
    Server providing pose connected
    Server providing: costmap connected
    Server providing: mesh connected
    Server providing: plan connected
    Server providing: aligned ptcloud connected
    

    Thanks.



  • Additionaly, the Follow Path button doesn't shows up on the GUI of voxl-portal.


  • Dev Team

    @darwin-keem,

    It looks like voxl-mapper failed to reach your goal point, resulting in it sending over the partial trajectory it solved for viewing but not giving you the option to follow the path. You can try giving the RRT solver another second or so by increasing the rrt_max_runtime_nanoseconds param, and it should be able to fully plan to your endpoint.

    The path generation code has been rewritten and thoroughly optimized in the latest dev package, so if you are still having issues with this planner it may be worth checking out some of the updates on our dev repo.


Log in to reply