Issue with aftermarket PMU and UAVCAN on FW 1.11.3



  • FW 1.11.3
    VOXL Flight

    We are using an aftermarket PMU because our drone is 12s. In order to get battery monitoring we are connecting it to the CAN bus connector - J1008 rather than the default I2C pins on J1013. However, we kept getting a "check battery error" when trying to arm on QGC. We have UAVCAN_ENABLE set to "Automatic Config". There is also no input on the voltage reading in the battery status window. As of right now I cannot figure out how to arm the drone in this firmware. I think that there is a conflict with the modalai FW and the FW releases from PX4.

    UAVCAN parameter -
    5c59cb91-e3a7-4bda-a7cc-e7f546b27a11-image.png

    Airframe and FW version -
    f70a0c17-1ee2-4899-a871-c8bb2c7b7f14-image.png

    Error message and battery status -
    3725370a-3854-4c03-8926-c4a75744a632-image.png b9f5fc43-cfa0-40a7-b496-8197206f3c58-image.png

    I did some digging because we had flown this system before and saw that we were running the FW 1.12.3 from PX4 stable releases. There are a lot more parameters supporting the UAVCAN, specifically for battery monitoring. UAVCAN_BAT_MON was set to default and the error went away and arming was no longer an issue.

    UAVCAN parameters -
    45f4de2e-9ed0-4f59-9017-61dac457d4c9-image.png

    Battery Status on FW 1.12.3 -
    c6e62c8b-e5a7-48ad-9925-6e423f014c36-image.png



  • The only drawback from using the firmware provided by PX4 (1.12.3) is that you lose functionality to adding RC channels while using a Joystick. Which is what we are doing for our project. Other than that, everything seems to work fine for what we are using.


  • Dev Team

    Hey @Caleb-Rievley ,

    Yes our production release is still at 1.11.3, but we have testing in the works on 1.13.

    Our roadmaps didn't align with PX4 1.12 really so we are going to jump to 1.13 (roughly after our internal testing and tuning has completed, which I say is about 1 month out, with the caveat that I'm always optimistic on timelines, otherwise sometimes you'd never start on some things 😂

    We haven't done a ton of testing on 1.12.3, have you tried 1.13 by chance?

    We will have a better chance at addressing this on the latest release if we find something.



  • @modaltb

    Thanks for the response! Good to know that you guys are working on 1.13, we found that the actuators tab (SYS_CTRL_ALLOC) was a nice addition to the stack. We have not tried to fly with the 1.13 version but we may start experimenting with it more in upcoming weeks. I can keep you updated with any issues if you would like?

    As far as the PMU issue above, I am sure that our after market device was ok to use.


  • Dev Team

    Please do, thanks!



  • @modaltb
    We were able to fly with 1.13 but i lost control of the servos' on PWM5-6(AUX passthrough 1-2). I tried to fix it with a custom mix file but was unsuccessful.

    Im now looking at the PX4-Autopilot code to see if i can add the PMU through UAVCAN to the 1.11 build.

    Im new to the architecture can u give me a few tips on where to start. Based on me looking around i think I need to be in the /src/drivers/ area?


  • Dev Team

    Have you asked in the px4.slack.com Slack channel? All of the developers are there and there is tons of good support. They would probably have better recommendations on how to add the driver properly than we would.


Log in to reply