mavros



  • On my VOXL Flight setup, I'm having trouble getting the Docker ROS image to communicate with the VOXL. I'm following the instructions from this link:

    https://docs.modalai.com/mavros/

    I changed the parameters in the /etc/modalai/voxl-vision-px4.conf file to include:

    "en_localhost_mavlink_udp":	true,
    

    I am able to communicate with the Docker image and can publish and subscribe to messages from it. I do see all the mavros topics, from inside the docker container, on the "native" VOXL shell, and from my remote computer connected over WiFi or via our MicroHard radio. However, the /mavros/state message indicates that there is no connection. rostopic echo /mavros/state gives only one message:

    header:
      seq: 0
      stamp:
        secs: 2228
        nsecs: 862914984
      frame_id: ''
    connected: False
    armed: False
    guided: False
    manual_input: False
    mode: ''
    system_status: 0
    ---
    

    The last messages on running ./run_mavros.sh from inside the Docker container are:

    ...
    ...
    [ INFO] [732.234354982]: Known MAVLink dialects: common ardupilotmega ASLUAV autoquad icarous matrixpilot paparazzi slugs standard uAvionix ualberta
    [ INFO] [732.234448888]: MAVROS started. MY ID 1.240, TARGET ID 1.1
    

    I also found this article about the MAVlink SDK and how to setup local communication:

    https://gitlab.com/voxl-public/voxl-docker-images/voxl-docker-mavsdk-python

    Given the version of the VOXL software on the system, it seems that we need this in /etc/modalai/voxl-vision-px4.conf instead of the above option:

    "en_secondary_qgc": true,
    "secondary_qgc_ip": "127.0.0.1",
    

    However, that did not work either. I get the same type message from rostopic echo-ing /mavros/state.

    I am able to plug into the FCU via USB and run mavros, by specifying the correct serial port on launch.

    The output of voxl-version for my current setup is:

    --------------------------------------------------------------------------------
    system-image:    ModalAI 2.2.0 BUILDER: ekatzfey BUILD_TIME: 2020-01-28_23:54
    kernel:          #1 SMP PREEMPT Tue Jan 28 23:55:02 UTC 2020 3.18.71-perf
    factory-bundle:  0.0.5
    sw-bundle:       0.0.5
    --------------------------------------------------------------------------------
    architecture:    aarch64
    processor:       apq8096
    os:              GNU/Linux
    --------------------------------------------------------------------------------
    voxl-utils:
    Package: voxl-utils
    Version: 0.4.6
    Status: install user installed
    Architecture: aarch64
    Installed-Time: 246
    
    --------------------------------------------------------------------------------
    

    Any help or direction on what to check next is greatly appreciated.



  • Thanks for the post! You are user #1 😉

    We made a change to voxl-vision-px4 some time back and I'm wondering if you are caught in the middle.

    https://gitlab.com/voxl-public/voxl-vision-px4/-/commit/e9259cff0ee61f320edd3b40ab01cf715715c8a7

    "Older" (a few months back) version of the program expected all traffic over port 14550, since then we've split up traffic for 14550 for external clients (e.g. QGC) and 14551 for onboard traffic.

    Notice here we are using 14551:
    https://gitlab.com/voxl-public/mavros_test/-/blob/master/run_mavros.sh#L7

    I wonder if updating this on your system to 14550 will get you going?

    The other option is to update the system image and then software suite to get the latest, if this is an option let me know.
    Thanks!
    Travis



  • The change of port worked for me. Thank you for the help.


Log in to reply