Quick question on micro hard resets and ip hopping issue.



  • Quick question. On the micro hard add-on board and usb standalone - the reset button instructions discuss 5sec hold down and 10sec hold down. Does the different timing determine Master or Slave reset configurations, or is it determined by the board? We are having an issue where the reset keeps making both Master with the same settings and I have to manually alter the settings in Micro hard. Also a new issue that is probably related is the micro hard DHCP server keeps assigning different IP addresses to the ground station. We adapted by telling QGroundControl the ip address of the VOXL, but it is forcing us to change our video streaming strategy. I'd like to know why suddenly this ip hopping seems to be happening.


  • Dev Team

    @RDPRobotics check out this page if you haven’t: https://docs.modalai.com/microhard-add-on-manual/

    It should answer any of your questions.

    In order to put the modem in slave mode you need to hold down the button for 5 seconds then release. If you hold for too long it’ll go into master mode.

    Did you use the voxl-configure-modem command to setup the static ip and modem service?



  • We followed the instructions to the letter except for the timing of the push. I'm guessing the master-slave difference might be causing an issue, even after resetting the one micro hard as slave?


  • Dev Team

    I’m order for the modems to talk to each other, one needs to be a master and one needs to be a slave.



  • I'm sorry my statement was not clear. I am fully aware of the master-slave relationship and requirements, but thank you for clarifying. I am stating that I wonder if having both of them first set by the master script then one manually changed (the usb standalone microhard) to slave properly and the correct ip address for it of 192.168.168.2 (what should be the default, different than 168.1) that something of them both being set by the master auto config script might be causing the ip address hopping. Every reboot of the system would result in the ip address of the ground station changing by one or two up/down.

    So that was what I was referring to - the fact that the DHCP server kept changing the ip address of the ground station (this only seemed to appear recently and so may be related to the master-slave auto setup not working due to my timing of the button press), while the setup instructions for connecting the voxl to QGC require an essentially fixed ip address unless one tells QGC what the ip address of the voxl is by setting up another connection in 'coms.'

    When I set a fixed ip address on the ground control station side it refused to take on the proper address. It would literally generate a random address. This could be a windows tablet issue, or the usb ethernet issue or a driver issue. If I set a fixed ip address on the microhard web interface page at the network-DHCP tab when a particular mac address connects to it, that system would actually hand out a different one than what I set it to. Am I misunderstanding, doesn't the micro hard DHCP decide what the ip address would be or is the voxl program choosing that/serving the ip address?

    Is the micro hard auto config file available on the repo somewhere to review?


  • Dev Team

    @RDPRobotics Apologies, I misread and thought the IP hopping was on the drone side. You should be able to set a static IP on the ethernet network interface on your Ground Station.

    I have little experience with Windows networking unfortunately (we mainly use Ubuntu around here), but I think you may have to do something like this: https://www.hellotech.com/guide/for/how-to-set-static-ip-windows-10



  • @tom I understand and I know many of the questions you get have to do with people not being informed about any of the hardware. I know micro hard and video, linux a good bit, command line I'm comfortable with, but I'm new to VOXL as of this project.

    Anyways interestingly we did that (setting static ip on windows), and Windows refused to set the static ip address we set. I think it either had to do with the groundcontrol tablet being a windows tablet but a panasonic tough book, perhaps an odd implementation or the USB ethernet interface of the micro hard somehow not allowing that to be set. The solution for the short term was knowing the VOXL ip address and setting qgroundcontrol to know that through the coms tab, but this wasn't desirable as my solution to the video streaming problem was to use ffmpeg and stream to the ground station's ip address. It can be broadcast as well and of course one could use one of the VOXL's streaming programs, but voxl-streamer doesn't appear to work with that video converter hardware or the setting is not obvious after a few hours of work, and ffmpeg works easily. I had issues getting voxl-uvc-streamer or whatever the name was working properly. It could be that it would work better with that hardware since it's supposed to support UVC better. So we failed to set the computer's ip address from either end, trying first one way and then the other. It's odd, and that's why I thought the auto setup script set something with the dhcp I'm not seeing and the two would each hand out a different ip address depending on who connects first perhaps, I don't know it is unclear.

    I was also curious what the time criterion is in the script - is it 5sec +- some range, or >5 but < 10 by some range, etc? A human will never press for exactly 5sec, and this switch is very awkward to press precisely and know it was pressed for that timing. I found a small plastic rectangle was best as it transmits the click sensation better than a finger tip or nail and that helped. It seemed like 5 seconds pressing the button would not cause a reset on our older of the two usb standalones we have. I think it might have an issue. The other one works fine if you could to 5 and release.


  • Dev Team

    @RDPRobotics If a standalone Microhard modem is plugged into your host PC / tablet, you can go into your host's browser and go to either 192.168.168.1 or 192.168.168.2 depending on whether the modem plugged in is in Master and Slave mode and it will open a Web GUI that you can use to change any settings you'd like manually, including slave / master mode. If the modem plugged in to your host is also connected via. Microhard network to the modem on your drone for example, you will also be able to access the web GUI for that modem as well.


  • Dev Team

    @RDPRobotics For video related questions, I would recommend you open a new thread as to separate the topics and get mode eyes on it.


Log in to reply