ADB devices not found



  • @tom I tried the adb for windows and it is working fine, I'm able to connect onto the voxl-cam via adb shell command.

    Still have a problem via wsl to see the devices from ubuntu client, but if is working from windows client for adb I suppose that the device is fine.


  • Dev Team

    @marian Okay that's some good news! Since you're able to ADB from windows that means the VOXL Cam itself is functional. It must be some permission issue. We recommend using Ubuntu 18 directly and none of our engineers here use Windows for software development so I'm not too familiar with WSL. Do USB devices need to be added manually? Not sure they're shared from windows to WSL automatically. You may also need to stop the ADB server from running on the Windows client in order for it to work in WSL. (adb kill-server)



  • @tom It's working just fine 🙂

    There were a few issues:

    1. when using WSL we need to start the server on windows via powershell and the first time will ask to set up the security access, just give access on both networks, this is used by wsl to give access to ubuntu client.

    2. On linux, if we install the adb via apt install, the adb version will be older and the connection with the server will not work. Should install it via platform-tools provided by Android studio.

    3. The cable. Using a micro-usb cable to connect the voxl-cam doesn't work every time, is recommended to use a usb 3 data cable to connect via this usb port.

    Once we follow all these, is working fine in all the environments : windows, wsl / ubuntu 20, and mac os 🙂

    Thanks for your help!


  • Dev Team

    @marian This is some really good information, thank you so much for your findings!



  • @marian Please I am having the same issue you had with ADB here. I installed ADB with Ubuntu but it I don't think it worked because its not Detecting my VOXL CAM yet.



  • @Bright-Nnadi Hi, did you install ubuntu on windows and using via wsl, or you have a linux machine with ubuntu installed that you use?



  • @marian i just installed ubuntu on windows but not via wsl



  • @Bright-Nnadi I understand. I followed the steps below and it works fine for me, I hope that will help you too.

    1. Installation steps :
      Install ADB for windows
      Install adb for ubuntu.

    Check the version on both systems. On ubuntu, if using apt will install an older version than Windows, so should install it via platform-tools provided by Android studio

    For Using ADB follow the steps below:
    a) Run PowerShell in Admin mode, and go to the folder where ADB is located
    There tape the command below:
    .\adb.exe -a -P 5037 nodaemon server

    That should connect and show the devices:
    adb.exe I 02-28 17:55:47 13580 13948 adb.cpp:171] c6f37030: already offline

    N.B.: The first time we run it, it will open a security window to give it access through the Firewall. Select the both, local and public network. It is needed to access the device through WSL (see step below).

    Into another PowerShell window can connect to the device via .\adb.exe shell

    b) on Ubuntu client :

    Take the IP address of the WSL from the windows station:
    ifconfig -> for me is something like 172.23.0.1 …

    Look into the /etc/resolv.conf => there should be the address below, if not change it to this one

    Run the command:
    adb -H 172.23.0.1 -P 5037 devices

    That should allow you to connect to adb device from Ubuntu client on Windows.



  • @marian Please how will install adb via AS, not familiar with it.



  • So I have Android studio installed now


Log in to reply