Having trouble taking off



  • Hello,

    Currently I am looking to just have the drone take off, hover for a few seconds and then land indoors. Nothing special.

    I have essentially the M500 drone that I just built and put together myself based on your actual M500 available in the shop.

    The issue is that after applying close to 70% throttle the drone still will not take off.

    • Drone does arm and the motors do spin slowly while idle in armed mode. The motors also do respond to my throttle stick and will increase in speed.

    • Drone is set in altitude mode and propeller orientation are set to be shown like in the M500 setup page. Although I am not 100% sure on the motor spin direction if someone could clarify.

    Some issues I am thinking is that when I tried to use position mode QGroundcontrol would complain since the GPS was not accurate indoors and gave horizontal positioning drift. Therefore I tried using altitude mode as a work around for this basic test. To do so I used both the PX4 parameter files

    sensors_disable_gps_mag.params
    ekf2_indoor_vio.params

    I have no intention of actually using VIO for the test but thought it might be necessary to use both those param files. I can confirm I do receive mavlink messages but I can see that in the ODOMETRY and LOCAL_POSITION_NED section that I do not get X or Y data back.

    Would not receiving the X or Y data on the ODOMETRY and LOCAL_POSITION_NED impact the takeoff of the drone in Altitude mode after it being armed?

    Also could someone confirm with me the proper motor spin direction?
    Front Left = CW, Front Right = CCW, Rear Left = CCW, Rear Right = CW


  • Dev Team

    Hi @Gordon8 ,

    One thing that caught me off-guard the first time I flew in position mode... at 50% throttle you are informing the system to stay steady, so taking off you will end up using a lot more throttle than you normally would expect.

    Here's the image I use to remember to spin directions (px4 motor layout)
    74ddb5d6-cdbc-4dc5-be58-33c7a9c2bded-image.png .

    I'm assuming you have something like a VOXL Flight Deck?



  • @modaltb
    Sorry for the very late reply but have been quite busy.

    Yeah we have been running the VOXL Flight Deck and we made sure that all required services are running.

    Yesterday we did a test flight again and we were able to get the correct x,y,z data and I set the drone to fly in position mode. Upon trying to takeoff the drone quickly flipped over and destroyed two of the propellers. (Before when I posted the original message the drone wouldn't takeoff at all and just spin the motors but now it actually tried to takeoff)

    I believe I know what the problem is but I want to confirm with you. I changed the motor spin direction and propellers to make sure they align with the image you posted and with the M500 documentation. After the crash I realized that in QGroundcontrol that when using the motor testing function it didn't align with the picture.

    For example spinning up motor 2 using QGroundControl would actually spin the physical motor 3 labelled on the diagram. Spinning motor 3 on QGroundControl would then spin the physical motor 2 labelled on the diagram.

    So on the drone physically all 4 motors are technically spinning in the correct direction.
    The problem is the mapping from physical drone to PX4/QGroundControl since they are mapped in different positions.

    Would you be so kind as to confirm that when you go into QGroundControl and test the motors that when you throttle up motor 2 the back left motor spins and that the motor positions labels 1,2,3,4 on QGroundControl correspond to the diagram you posted.

    If this is true can the change be done in software or do I need to take apart the drone and change the ESC servo wire positions on the breakout board.


Log in to reply