Unable to connect to QGroundControl

  • I've been trying to check the drone configuration and services but again I'm getting an error, below:

    Vehicle 1 did not respond to request for parameters. This will cause QGroundControl to be unable to display its full user interface.

    The QGroundControl (Mobile - iPhone) Version: is v4.0.1.0 (The mentioned error message appears for mobile only)
    QGroundControl (Windows Desktop) - Version: Development HEAD:f9ebc2720 2021-08-31 06:55:11 +0000 (Although no error message is shown, it won't connect anyway)
    I've tried Wifi networks uusing both 2.4GHz and 5GHz.

    From the link https://docs.modalai.com/Qualcomm-Flight-RB5-sdk-services/#how-to-configure
    I could not see if there is any further configuration to be done to have it working.

    Let me know.

  • Dev Team

    Hi @Francesco-Jacomel ,

    Double checking, you've used this Windows QGC setup with other vehicles? I tend to find network/firewall/port issues that affect Windows.

    I'm sure you've gone through and pings RB5 from desktop and vice versa to prove IP comms.

    There's a config file that is used (similar to PX4 sensors service files) at /etc/modalai/full-m0052.config (small info here)

    In there, you'll find where we are starting MAVLink instances (amongst other things). You can change from UDP broadcast (usage)

    Thanks and let us know how it goes!

  • Hi @modaltb ,

    Pings are working between the device and drone.
    From desktop to drone it isn't so a firewall might be blocking, but anyway, the desktop should not be an issue as I won't be using it, my focus is to have it working through the cellphone application.

    I've tried changing the config file but keep having the same message there.
    I'll change the devices here and give it another try.

  • Let me know if you have any specific changes that would be applied to the mentioned file, I've just tried changing the mavlink start parameters to these below:

    mavlink start -u 14556 -t <my device IP>

    I've removed -m and -n for each tests I was running, initially it was ending with the -n lo -m custom from the sample line.

  • Hi @Francesco-Jacomel,

    We are having a hard time reproducing your issue on our end. Here are the steps we took in order to connect to QGroundControl (Mobile - iPhone) Version 4.0.10

    1. Setup wifi on RB5 by modifying the /data/misc/wifi/wpa_supplicant.conf with our wifi, rebooting the RB5, and connecting our mobile device to the same network which we had setup on the RB5
    2. Open QGroundControl on our mobile device and wait for a connection

    Following these steps we were able to successfully connect. If these steps were also taken on your end then we think there may be a UDP broadcasting conflict that is causing the issue. We can troubleshoot this by having you make some modifications to your full-m0052.config file on target.

    You'll want to disable MAV_BROADCAST as well as add your Iphone's IP in the /etc/modalai/full-m0052.config file on target. Configure this file in the appropriate section so it looks as follows:

    # This is needed for altitude and position hold modes
    flight_mode_manager start
    # Add this line to disable MAV_BROADCAST
    param set MAV_BROADCAST 0
    # Edit this line to add your phones IP
    mavlink start -x -u 14557 -r 40000 -t <Iphone IP>
    mavlink start -u 14556 -t -n lo -m custom
    sleep 1
    mavlink stream -u 14557 -s HIGHRES_IMU -r 5
    mavlink stream -u 14557 -s ATTITUDE -r 5
    mavlink stream -u 14557 -s RC_CHANNELS -r 20
    sleep 1

    Make sure to fill in the IP with your mobile phones IP. On an IPhone you can get the IP by going to settings>Wi-Fi and clicking the info button on your network. After configuring these parameters reboot your RB5 and open the QGC application on the mobile phone and see if the issue is still present.

    Thank you for being patient with us. If needed, we can also arrange a phone call to try and further troubleshoot this issue.

Log in to reply