LiDAR not showing up via I2C on J13

  • Hello, I'm having trouble getting LiDAR to show up with the Flight Core via the J13 I2C connection and wanted to check it is supported in the hardware.

    I'm helping a friend who has a Flight Core, I've tried connecting a LiDAR Lite v3 via the I2C interface (J13) and changing the appropriate setting (SENS_EN_LL40LS) but it still won't show up. I also tried troubleshooting via the PWM input option with another unit but I'm not sure if Flight Core supports a PWM input there as it did not show up with that method either.

    I've verified the LiDAR should be receiving 5V via pin 1 on plug J10, and tested it with multiple physical LiDAR units, so we can rule out voltage and a bad LiDAR unit. I've primarily been using VOXL Flight for several projects and the LiDAR has always worked perfectly with no issues so this is proving tricky to troubleshoot.

    Does the Flight Core support a LiDAR input via I2C connection on J13? Any other ideas for troubleshooting?

    Thanks in advance!

  • Dev Team

    Hi @Ansel-Misfeldt ,

    I've not personally tried this device (LiDAR Lite v3), but the I2C interface on the Flight Core's J13 is the "same" as VOXL-Flight's J1011.

    When you are using it on VOXL-Flight, what connector are you using?

    This looks to be loaded with the distance_sensordrivers, which are enabled by default:

    Have you attempted starting via NSH command line? It appears to be ll40ls start -X from here

  • @modaltb Interesting, that's good to know they should be identical (what I assumed), that's why I was puzzled when it didn't seem to work.

    On VOXL Flight we're using port J13 and it's always worked perfectly without issue the first time we're wired up a new unit.

    I have not tried starting via the command line, but that's a good idea to try.

    My best guess is a loose connection in the wiring somewhere or a pin not making good contact on the board. If it should be working the most obviously problem is user error on our part or something not making contact properly.

    We ended up sending them one of our VOXL Flight units where we knew it worked perfectly each time instead of using the Flight Core because they were in a rush to get things working.

    Thanks for the suggestions!

Log in to reply