LiDAR not showing up via I2C on J13

  • Hello, I'm having trouble getting LiDAR to show up with the Flight Core via the J13 I2C connection and wanted to check it is supported in the hardware.

    I'm helping a friend who has a Flight Core, I've tried connecting a LiDAR Lite v3 via the I2C interface (J13) and changing the appropriate setting (SENS_EN_LL40LS) but it still won't show up. I also tried troubleshooting via the PWM input option with another unit but I'm not sure if Flight Core supports a PWM input there as it did not show up with that method either.

    I've verified the LiDAR should be receiving 5V via pin 1 on plug J10, and tested it with multiple physical LiDAR units, so we can rule out voltage and a bad LiDAR unit. I've primarily been using VOXL Flight for several projects and the LiDAR has always worked perfectly with no issues so this is proving tricky to troubleshoot.

    Does the Flight Core support a LiDAR input via I2C connection on J13? Any other ideas for troubleshooting?

    Thanks in advance!

Log in to reply