Docker daemon fails to start VOXL



  • It looks like I'm getting an invalid argument error with the --raw-logs argument.

    • docker images or docker ps doesn't want to work because it says it cannot connect to docker daemon (is it running?)

    • voxl-configure-support.sh didn't want to work, because it says it cannot connect to docker daemon (is it running?).

    • Executing systemctl restart docker && systemctl status docker fails to restart docker.

    ~ # systemctl restart docker
    ~ # systemctl status docker
    ā— docker.service - Docker Application Container Engine
    Loaded: loaded (/lib/systemd/system/docker.service; disabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Thu 1970-01-01 00:02:16 UTC; 1s ago
    Docs: http://docs.docker.com
    Process: 3411 ExecStart=/usr/bin/docker daemon -H fd:// --raw-logs (code=exited, status=2)
    Main PID: 3411 (code=exited, status=2)

    Jan 01 00:02:16 apq8096 systemd[1]: Started Docker Application Container Engine.
    Jan 01 00:02:16 apq8096 docker[3411]: flag provided but not defined: --raw-logs
    Jan 01 00:02:16 apq8096 docker[3411]: See '/usr/bin/docker daemon --help'.
    Jan 01 00:02:16 apq8096 systemd[1]: docker.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
    Jan 01 00:02:16 apq8096 systemd[1]: docker.service: Unit entered failed state.
    Jan 01 00:02:16 apq8096 systemd[1]: docker.service: Failed with result 'exit-code'.

    I would like to fix this without reflashing the firmware to factory default if possible.

    Thanks a lot



  • Hello!

    We can't use the original docker service file on voxl as a few extra steps are required for docker to run on our platform. Both the installation of the voxl-docker-support package and execution of voxl-configure-docker-support.sh try to stop and disable docker.service as it gets in the way.

    Instead it is replaced by our own service files which should be enabled by the voxl-configure-docker.sh script. What is the output you see when you run this script?

    Best,
    James


Log in to reply