Failed to download http://voxl-packages.modalai.com/stable



  • Hi,

    I tried to update my package using wireless internet.

    I already check wireless connection.

    But, I cannot download and update packages using opkg command.

    yocto:/# sudo opkg update 
    Downloading http://voxl-packages.modalai.com/stable/Packages.gz.
    wget: bad address 'voxl-packages.modalai.com'
    Downloading file:///home/root/voxl-suite-ipk/Packages.gz.
    Updated source 'local'.
    Collected errors:
     * opkg_download_backend: Failed to download http://voxl-packages.modalai.com/stable/Packages.gz, wget returned 1.
    

    I visited website as "http://voxl-packages.modalai.com/stable"
    as you can see this picture, I found this site is not secure in firefox.

    Q1) Is this ok to download package even though the site is not secure?

    cea4c175-8aff-4d8f-9151-268ef20cb428-image.png


  • Dev Team

    Hi @shlee853 ,

    I didn’t setup SSL certificates for the package repo to simplify delivery on target, but this is the valid URL and is safe to proceed!

    Travis



  • @modaltb

    I tried to wget on host PC ans works fine

    swift@swift-HP-Pavilion-dv6-Notebook-PC:~/git/voxl-suite$ wget http://voxl-packages.modalai.com/dev/Packages.gz--2021-05-29 07:14:28--  http://voxl-packages.modalai.com/dev/Packages.gz
    Resolving voxl-packages.modalai.com (voxl-packages.modalai.com)... 35.215.116.197
    Connecting to voxl-packages.modalai.com (voxl-packages.modalai.com)|35.215.116.197|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 4518 (4.4K) [application/octet-stream]
    Saving to: ‘Packages.gz.1’
    
    Packages.gz.1               100%[==========================================>]   4.41K  --.-KB/s    in 0.006s  
    
    2021-05-29 07:14:28 (699 KB/s) - ‘Packages.gz.1’ saved [4518/4518]
    
    swift@swift-HP-Pavilion-dv6-Notebook-PC:~/git/voxl-suite$ 
    

    But, when I tried to wget on voxl, it cannot download Packages.gz with bad address.

    yocto:/# wget http://voxl-packages.modalai.com/dev/Packages.gz
    wget: bad address 'voxl-packages.modalai.com'
    

    my wifi connection is ok.

    Thanks,


Log in to reply