How to record high resolution camera frames/videos?



  • Hi everyone,
    I am currently working with a Sentinel dev drone (VOXL2) on which voxl-camera-server version 1.3.5 and voxl-streamer version 0.4.1 are running. I tried to save frames through voxl-logger, but the saved images have a resolution preview_width x preview_height = 1280 x 720 instead of snapshot_width x snapshot_height = 3840 x 2160 (as specified in the voxl-camera-server.conf file). Is it possible to save the frame (and also stream the video) in the original format (3840 x 2160) and NOT in the preview format (1280 x 720)?
    Thank you in advance for your response.



  • The frames that go through logger/streamer are the preview stream, to take a snapshot run voxl-send-command hires snapshot <file path> and it will save a full resolution jpeg snapshot to the filesystem. You can also not provide a file path and it will save to /data/snapshots/



  • Thank you for your quick response. I tried to use the command that you suggested

    voxl-send-command hires snapshot
    

    After running this command the console prompts

    Successfully sent command to /run/mpa/hires/control
    

    However no path /data/snapshots/ is created and no .jpg is saved in the /data/ folder. If I try to run again the same command the following response appears

    Unable to find valid pipe that accepts control commands at: hires
    

    The only way to retry to take another snapshot is to reboot the system, but it keeps not saving any images.



  • Sounds like an error occurred, what does journalctl -u voxl-camera-server say after running the commands?



  • Feb 09 11:44:02 m0054 systemd[1]: Started voxl-camera-server.
    Feb 09 11:44:04 m0054 bash[1394]: ------ voxl-camera-server: Camera server is now running
    Feb 09 11:44:04 m0054 bash[1394]: WARNING: Camera stereo_front recieved much newer master than child
    Feb 09 11:44:04 m0054 bash[1394]: WARNING: Camera stereo_rear recieved much newer child than master 
    Feb 09 11:55:32 m0054 bash[1394]: Camera: hires taking snapshot (destination: /data/snapshots/hires-
    Feb 09 11:55:33 m0054 bash[1394]: free(): invalid pointer
    Feb 09 11:55:33 m0054 systemd[1]: voxl-camera-server.service: Main process exited, code=killed, stat
    Feb 09 11:55:33 m0054 systemd[1]: voxl-camera-server.service: Failed with result 'signal'.
    


  • I am having the same problem. I created a the snapshots folder too, and the camera server crashes.



  • @afdrus instead of rebooting, you can restart the server with: systemctl restart voxl-camera-server


Log in to reply