IMU calibration failed on voxl-configure0-snav



  • Hi,

    I'm on testing VOXL flight deck. I tried to calibrate IMU using configured voxl-configure-sanv command, but it failed because of SN.

    could you please let me know how to sucess IMU calibaration?

    Thanks,

    yocto:/# voxl-configure-snav

    Which camera configuration are you using?
    0 None
    1 Tracking + Stereo
    2 Tracking Only
    3 Hires + Stereo + Tracking (default)
    4 Hires + Tracking
    5 TOF + Tracking
    6 Hires + TOF + Tracking
    7 TOF + Stereo + Tracking
    8 Hires Only
    9 TOF Only

    3
    attempting to use camera configuration 3
    adding override_cam_id value=1 to /etc/snav/camera.downward.xml
    adding override_cam_id value=2 to /etc/snav/camera.stereo.xml
    Writing new configuration to /etc/modalai/voxl-camera-server.conf:
    {
    "version": 0.2,
    "port_J2": {
    "name": "hires",
    "enabled": true,
    "type": "hires",
    "api": "hal3",
    "rotation": 180,
    "frame_rate": 30,
    "override_id": -1,
    "auto_exposure_mode": "isp",
    "preview": {
    "enabled": true,
    "width": 640,
    "height": 480,
    "format": "nv21"
    },
    "video": {
    "enabled": false,
    "width": 1024,
    "height": 768,
    "format": "h264"
    },
    "snapshot": {
    "enabled": false,
    "width": 1024,
    "height": 768,
    "format": "jpg"
    }
    },
    "port_J3": {
    "name": "stereo",
    "enabled": true,
    "type": "stereo",
    "api": "hal3",
    "rotation": 0,
    "frame_rate": 30,
    "override_id": -1,
    "auto_exposure_mode": "mvcpa",
    "mv_cpa_filter_size": 2,
    "mv_cpa_exposure_cost": 0.75,
    "mv_cpa_gain_cost": 0.25,
    "mv_cpa_en_histogram": true,
    "preview": {
    "enabled": true,
    "width": 1280,
    "height": 480,
    "format": "nv21"
    }
    },
    "port_J4": {
    "name": "tracking",
    "enabled": true,
    "type": "tracking",
    "api": "hal3",
    "rotation": 0,
    "frame_rate": 30,
    "override_id": -1,
    "auto_exposure_mode": "mvcpa",
    "manual_gain": 1000,
    "mv_cpa_filter_size": 2,
    "mv_cpa_exposure_cost": 0.75,
    "mv_cpa_gain_cost": 0.25,
    "mv_cpa_en_histogram": true,
    "preview": {
    "enabled": true,
    "width": 640,
    "height": 480,
    "format": "raw8"
    }
    }
    }

    Which physical configuration is this for?

    1. 200_quad_2S_pack 4) voxlcam_upside_down_tracking_cam
    2. 230_quad_3S_pack 5) voxl_230_3s_quad_secondary_imu
    3. voxlcam_upright_tracking_cam
      #? 4
      reloading systemd services
      stopping imu_app

    the next step is static IMU calibration
    Make sure the quadcopter or VOXL-CAM is flat/upright (roll/pitch=0)
    be patient, this will take 20-30 seconds
    PRESS ENTER to start static IMU calibration

    Starting SNAV: Warning: snav_dronecontroller.service changed on disk. Run 'systemctl daemon-reload' to reload units.
    Done
    FastRPC call to update data failed

    Detected likely failure in SN. Ensure it is running and attempt calibration call again.


Log in to reply