VOXL2 IO board only spinning 4 of 6 motors



  • Hello all,

    I'm having a problem getting the VOXL2 to spin all 6 motors of my hexarotor. I am able to spin 4 motors without a problem, but not all 6. I have, what I believe, everything hooked up correctly. J19 of the VOXL2 pins 9-12 are hooked up to VOXL2 IO J4 pins 1-4, VOXL2 IO is hooked up to the PWM breakout where I have all 6 motors hooked up (I've tried different configurations of connections to verify the motors/ESCs are okay), and I have the Spektrum receiver hooked up and bound to my transmitter.

    I have PX4 firmware 1.4.26beta running onboard the VOXL2 and I it looks like the VOXL 2 IO board is running just fine. I have a solid green LED, 2Hz blinking blue LED, and an OFF orange LED. I have changed the mixer file quad_x_io.main.mix (which I had to create as I couldn't find the file) to contain the following: R: 6x 10000 10000 10000 0.

    I'm unsure if I have the firmware flashed correctly on both the VOXL2 and the VOXL2 IO board; I was looking at this webpage and I'm a little unsure about the instructions and if this may be what the problem is since I really haven't run many of the commands.
    Thanks.


  • Dev Team

    Hi @Isaac_j ,

    Let me check into this. The file should be at /usr/lib/rfsa/adsp/quad_x_io.main.mix, can you verify that it is not there?

    The mixer runs on the DSP, and that's a folder that the DSP has access to.

    The PWM functionality is available from the voxl-px4 'dev' channel, the file (setup for quad) is here in source as reference:

    https://github.com/modalai/px4-firmware/blob/voxl-dev/ROMFS/px4fmu_common/mixers/quad_x_io.main.mix

    And get's packaged here in the .deb package:
    https://gitlab.com/voxl-public/voxl-sdk/services/voxl-px4/-/blob/dev/make_package.sh#L130


Log in to reply