hires camera crashes camera server

  • I was working on streaming the hires camera frames to ROS and i noticed that whenever i try to read from the hires pipe, the camera server crashes. I have identified the following

    1. I dont think its a hardware issue as i tried connecting my board with a brand new camera without any flex cable extension and the issue persists. I am also facing this problem with 3 other boards

    2. When the camera server is started, i get a few seconds worth of frames and then the crash happens. If I have the voxl portal open with the option to view the hires selected and then start the camera server i can see the camera frames for a few seconds and then it freezes. While the camera server is frozen, I see the stream from the tracking and stereo seem fine for a few more seconds after which all camera streams stop and the camera server crashes

    3. The error seen is -19 which can be seen by starting the camera server using -d 0 parameter and when checking the journalctl for the camera server i see the following
      Sep 05 22:24:10 voxl6 bash[2117]: Segmentation fault:
      Sep 05 22:24:10 voxl6 bash[2117]: Fault thread: CAM_METADATA(tid: 3214)
      Sep 05 22:24:10 voxl6 bash[2117]: Fault address: 0x581
      Sep 05 22:24:10 voxl6 bash[2117]: Unknown reason

    4. I have also tried updating to the latest firmware v3.8.0-0.7

    5. I tried multiple resolution configuration (640x480, 1280x720, 1920x1080 and 4000x3000)

    If anyone can help me out, that would be appreciated


  • @vivek-rk For anyone looking for a quick fix, you can use the voxl rtsp server for the hires only, for MPA support use the add-mpa-support branch

Log in to reply