No lock with GPS



  • Hello,
    My system image on VOXLCAM is 3.8.0 and px4 firwmare version is Modalai 1.11.3-0.2.3. I bought ublox M8N GPS from here. I wanted to try GPS + VIO based ADFS flight in outdoor and indoor environment.
    I am unable to get 3D fix for my GPS. I have correctly set parameter GPS_1_CONFIG to GPS_1 and also connected GPS to J10 connector on flightcore. My EKF2_AID_MASK is set to '1' for GPS only flight. I am constantly getting BLUE LED blinking which means no GPS fix. I am trying this outdoor with clear sky view.

    Here is my Nuttx QGC logs and GPS status
    Screenshot from 2022-09-02 07-56-16.png

    I also tried cold, warm and hot reset but without any luck.
    Any help in further debugging would be highly appreciated.


  • Dev Team

    The GPS not getting a fix doesn't really have anything to do with Flight Core or other VOXL configuration

    Since it is a cold start in a new location, it can take minutes to initialize the first time. Otherwise do you have electromagnetic interference somewhere?

    Can you move the GPS further from any electronics?



  • @Chad-Sweet I have GPS mounted over VoxlCam hardware with distance of approximately 10 cms. I also tried moving GPS towards backside similar to seeker but still I wasn't able to get fix. I have waited for an hour to get fix but still facing issues. Do I need to configure GPS module by any chance with u-center : https://www.u-blox.com/en/product/u-center ?
    As far as electromagnetic interference is concerned I don't think there is anything in very close vicinity of GPS.


Log in to reply