Invalid option (not able to select imu1 for qvio server)

  • Hi,
    I have flashed the new image for VOXL in my voxl-cam board, and was trying configuring qvio server. output is shown below.

    voxl:/$ voxl-configure-qvio 
    Starting Wizard
    Do you want to reset the config file to factory defaults?
    1) yes
    2) no
    #? 1
    wiping old config file
    loading qvio config file
    Creating new config file: /etc/modalai/voxl-qvio-server.conf
    Do you want to enable the voxl-qvio-server service to allow
    visual inertial odometry?
    1) yes
    2) no
    #? 1
    Now we are going to do a preliminary configuration of /etc/modalai/voxl-qvio-server.conf
    Which IMU should voxl-qvio-server use? We recommend
    imu0     for VOXL Flight all-in-one board.
    imu1     for VOXL1 and VOXL-CAM
    imu_px4  for RB5 Flight 5G
    imu_apps for VOXL2
    1) imu0
    2) imu1
    3) imu_px4
    4) imu_apps
    #? 1
    invalid option
    #? 2
    invalid option
    #? 3
    enabling  voxl-qvio-server systemd service
    starting  voxl-qvio-server systemd service
    Done configuring voxl-qvio-server

    here I am not able to select both imu0 and imu1 for voxl-qvio-server it's showing 'invalid option' but able to select imu_px4.
    can you tell me how can I rectify this problem.
    Thank you!

  • Dev Team


    The bugfix for this is in VOXL SDK 0.8 and newer. If for some reason you need to change the imu that qvio uses from the default configured by voxl-configure-mpa then you can edit the config file /etc/modalai/voxl-qvio-server.conf manually or use one of the shortcut command line arguments listed in the voxl-configure-qvio --help text such as:

    voxl-configure-qvio factory_enable_imu0
    voxl-configure-qvio factory_enable_imu1

    Hope this helps,

Log in to reply