DHCP/Static IP Ethernet Reconfiguration

  • We set one of our VOXL 2's to use a static IP ( sudo ifconfig eth0 X.X.X.X. netmask Y.Y.Y.Y) and now cannot get it back to being assigned an IP by the DHCP server - it now boots and stays on 169.254.4.X. Our other VOXL 2's are assigned addresses by the DHCP server out of the box; we have installed netplan and attempted to switch between DHCP and a static IP via netplan but are only getting DHCP. How can we fix this so that it will get a DHCP address assigned, and what method should we use to switch between a static IP and DHCP in the future?

  • Dev Team

    If you want it to stay at the IP specified in sudo ifconfig eth0 X.X.X.X. netmask Y.Y.Y.Y you'd have to run that command on every boot, which could be done with a systemd service

  • Hi Tom, That's actually not what I'm looking for. I'm trying to understand:
    a. What may have been overwritten or changed as a result of that command so that the VOXL is no longer assigned an IP by our DHCP server. Our other two VOXL 2's where we have not run that command are assigned IP's by the DHCP server with no issues.
    b. What process or command you would recommend for setting a static IP on the VOXL's in the future that will not interfere with switching back to DHCP regularly.

  • Dev Team

    I haven’t seen that command do anything that is persistent after a reboot. Any chance you ran any of the voxl-modem-configure setup? Depending on what you may have done there it may have written an IP to /etc/network/interfaces

  • Hey Tom - in checking this I noticed that /etc/network/interfaces existed on the problem VOXL and not on the other two, so I deleted it and now I can set a static IP that will reset and be assigned a DHCP IP after reboot. Thanks!

  • Dev Team

    @I_Dwyer Great! Sounds like that VOXL had been run through the voxl-modem-configure setup and the others had not.

    One other thing I would check is see if the voxl-modem service is enabled with systemctl status voxl-modem, if it's enabled on that one and disabled on the others you may want to disable it with systemctl disable voxl-modem as you may see some network inconsistencies between VOXLs otherwise.

Log in to reply