voxl-tflite-server abort



  • I'm trying to run voxl-tflite-server on an m500, but when I run the command, this is the output:

    
    =================================================================
    skip_n_frames:                    5
    =================================================================
    =================================================================
    model:                            /usr/bin/dnn/ssdlite_mobilenet_v2_coco.tflite
    =================================================================
    =================================================================
    input_pipe:                       /run/mpa/hires/
    =================================================================
    
    ------VOXL TFLite Server------
    
    Aborted
    

    I tried running voxl-configure-tflite again, but same result. My configuration file from /etc/modalai/voxl-tflite-server.conf looks like this:

    /**
     * This file contains configuration that's specific to voxl-tflite-server.
     *
     * skip_n_frames - how many frames to skip between processed frames. For 30hz
     *                   input frame rate, we recommend skipping 5 frame resulting
     *                   in 5hz model output.
     * model         - which model to use. Currently support mobilenet for
     *                   object detection or midas for monocular depth
     * input_pipe    - which camera to use (tracking or hires).
     */
    {
            "skip_n_frames":        5,
            "model":        "/usr/bin/dnn/ssdlite_mobilenet_v2_coco.tflite",
            "input_pipe":   "/run/mpa/hires/"
    

  • Dev Team

    Hi @Isabella-Yu,

    Could please share the output of running voxl-version and voxl-inspect-services -v? It would also be good to know if the voxl-tflite-server code has been modified in any way.



  • @Matt-Turi
    Here's the output of voxl-version

    cat: /etc/modalai/voxl-software-bundle-version.txt: No such file or directory
    --------------------------------------------------------------------------------
    system-image:    ModalAI 3.3.0 BUILDER: ekatzfey BUILD_TIME: 2021-06-06_19:28
    kernel:          #1 SMP PREEMPT Sun Jun 6 19:41:01 UTC 2021 3.18.71-perf
    factory-bundle:  1.0.1 (Yocto installation)
    --------------------------------------------------------------------------------
    architecture:    aarch64
    processor:       apq8096
    os:              GNU/Linux
    --------------------------------------------------------------------------------
    voxl-suite:
    Package: voxl-suite
    Version: 0.5.0
    Depends: libjpeg_turbo (>= 9.0.4), libmodal_exposure (>= 0.0.2), libmodal_json (>= 0.3.6), libmodal_pipe (>= 2.1.1), librc_math (>= 1.1.5), libvoxl_cutils (>= 0.0.2), libvoxl_io (>= 0.5.4), mavlink-camera-manager (>= 0.0.2), mongoose (>= 7.3.0), opencv (>= 4.5.2-2), openmp (>= 10.0.2), voxl-camera-calibration (>= 0.1.1), voxl-camera-server (>= 0.8.1), voxl-cpu-monitor (>= 0.2.0), voxl-dfs-server (>= 0.2.2), voxl-docker-support (>= 1.1.3), voxl-gphoto2 (>= 0.0.5), voxl-imu-server (>= 0.9.1), voxl-mavlink (>= 0.0.2), voxl-modem (>= 0.12.0), voxl-mpa-tools (>= 0.3.6), voxl-nodes (>= 0.2.0), voxl-portal (>= 0.1.2), voxl-qvio-server (>= 0.3.4), voxl-streamer (>= 0.2.6), voxl-tag-detector (>= 0.0.2), voxl-tflite (>= 2.2.3), voxl-tflite-server (>= 0.1.5), voxl-utils (>= 0.8.4), voxl-vision-px4 (>= 0.9.5), voxl-vpn (>= 0.0.3)
    Status: install user installed
    Architecture: all
    Installed-Time: 2166
    

    Here's the output of `voxl-inspect-services -v"

     Service Name          |  Version  |  Enabled  |   Running   |  CPU Usage
    ----------------------------------------------------------------------------
     docker-autorun        |    1.1.3  |  Enabled  | Not Running | Not Running
     docker-daemon         |    1.1.3  |  Enabled  |   Running   |     1.0
     modallink-relink      |   0.12.0  | Disabled  | Not Running | Not Running
     voxl-camera-server    |    0.8.1  |  Enabled  |   Running   |     7.1
     voxl-cpu-monitor      |    0.2.0  |  Enabled  |   Running   |     0.0
     voxl-dfs-server       |    0.2.2  |  Enabled  |   Running   |     8.0
     voxl-drogon-detector  |    0.3.4  | Disabled  | Not Running | Not Running
     voxl-imu-server       |    0.9.1  |  Enabled  |   Running   |     4.4
     voxl-modem            |   0.12.0  | Disabled  | Not Running | Not Running
     voxl-portal           |    0.1.2  |  Enabled  | Not Running | Not Running
     voxl-qvio-server      |    0.3.4  |  Enabled  |   Running   |     0.0
     voxl-streamer         |    0.2.6  | Disabled  | Not Running | Not Running
     voxl-tag-detector     |    0.0.2  |  Enabled  | Not Running | Not Running
     voxl-tflite-server    |    0.8.5  |  Enabled  | Not Running | Not Running
     voxl-time-sync        |    0.9.5  | Disabled  | Not Running | Not Running
     voxl-vision-px4       |    0.8.5  |  Enabled  |   Running   |     4.0
     voxl-wait-for-fs      |           |  Enabled  |  Completed  |  Completed
    
    

  • Dev Team

    It looks like you have a custom version of voxl-tflite-server running - voxl-inspect-services shows v0.8.5 and we are currently at v0.2.7. Is this correct?



  • @Matt-Turi I actually don't have a custom version running, so I don't know how that happened. I'll reinstall voxl-tflite-server from the voxl packages page and see if that fixes things


  • Dev Team

    Please let me know if that resolves the issue!



  • @Matt-Turi I downloaded voxl-tflite-server_0.1.8.ipk from http://voxl-packages.modalai.com/stable/, pushed it to the drone via adb, and ran opkg install voxl-tflite-server_0.1.8.ipk. However, it seems that 0.1.8 is already installed:

     * opkg_prepare_file_for_install: Refusing to load file 'voxl-tflite-server_0.1.8.ipk' as it matches the installed version of voxl-tflite-server (0.1.8).
    

    I tried installing version 0.2.0 from dev instead, but it requires upgrading libmodal_pipe, libmodal_json, and voxl-opencv and I don't really want to do an upgrade right now in fear of breaking things 😞


  • Dev Team

    To force a fresh installation when it is the same version you have loaded, you can give opkg the flag: --force-reinstall to reinstall without needing to upgrade. The full command then would be:

    opkg install voxl-tflite-server_0.1.8.ipk --force-reinstall



  • @Matt-Turi that did reinstall voxl-tflite-server 0.1.8, but still having the abort issue.
    voxl-version gives the same output, and voxl-inspect-services -v says the version of voxl-tflite-server is 0.1.8 as expected


  • Dev Team

    @Isabella-Yu,

    I flashed a VOXL with the 3.3.0 system image and installed voxl-tflite-server v0.1.8 but was unable to recreate the abort issue you are seeing. voxl-tflite-server is a very power-hungry application, and I have seen issues like this arise from a bad apm/power connection to the drone. If this is not the cause, it may be worth attempting to reflash your system after backing up any important files. The latest stable release for voxl is VOXL Platform 3.8.0-0.7.



  • @Matt-Turi Yep, turns out switching to wall power fixed it. My battery power was too low. Thanks!


Log in to reply