voxl-camera-server.conf tracking camera settings not applying



  • Trying to change framerate and set manual exposure for the tracking camera via voxl-camera-server.conf file, but the changes I apply don't stick. Upon running voxl-inspect-cam the framerate always defaults to 30 fps, showing my changes haven't applied. Is there some override setting I need to change?



  • Would just like to clarify, editing the config file successfully changes the framerate / exposure for the hires camera. It doesn't work for stereo or tracking though


  • Dev Team

    Hi Jonathan,

    The underlying pipelines for the CV sensors are all delicately built and only support very specific resolutions. I'll update our documentation to better reflect this, but in general: The stereo pipeline can only do 30hz(for now, we're working on this) since it's very custom and the tracking camera can do 30,60,90, and 120hz. The hires camera is more standard and has more robust pipelines implemented to support more standard video stream configurations.

    As for the manual exposure/gain, have you set the auto exposure mode to "off", if not you're just setting up the starting point for the camera and the AE library will still perform it's usual duties.

    If you're still having issues after this let me know and we can dig through more of what you're seeing.


Log in to reply