voxl-suite install issue

  • Hi,

    I'm having trouble installing the voxl-suite package, due to an error installing the voxl-libgphoto2 package:

    Preparing to unpack .../voxl-libgphoto2_0.0.4_arm64.deb ...
    Unpacking voxl-libgphoto2 (0.0.4) ...
    dpkg: error processing archive /data/voxl-suite-offline-packages/./voxl-libgphoto2_0.0.4_arm64.deb (--unpack):
     trying to overwrite '/usr/include/gphoto2/gphoto2-abilities-list.h', which is also in package libgphoto2-dev:arm64 2.5.16-2
    dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Do you know how I might fix this?

  • Dev Team

    Is this on a freshly flashed board or did you already install some things with apt-get, like gphoto2 development libraries? The error says that it is trying to avoid overwriting an existing file. There is a flag you can pass to dpkg to force it to overwrite files if you are okay with it doing that. Are you planning to use gphoto2 or are just trying to get rid of the error?

  • @Eric-Katzfey so I also tried deleting /usr/include/gphoto2, and it still gave the same error. I don't think I had installed gphoto2 separately, but it wasn't a completely clean install. I had to install ROS melodic, and it uninstalled parts of the voxl sdk, and I was trying to reinstall voxl-suite. I don't necessarily need gphoto2, but it's part of what apt tries to install when I run apt install voxl-suite.

    Side question: I saw that there was /opt/ros/melodic that came with the voxl image, but there was no setup.bash to source, or is this located elsewhere on the system?

Log in to reply