voxl_mpa_to_ros



  • I'm following the instructions given here to use voxl_mpa_to_ros. Everything runs fine so long as I run the command:

    roslaunch voxl_mpa_to_ros voxl_mpa_to_ros.launch
    

    However, when I run the command ```

    voxl-mpa-to-ros
    

    I get the following:

    yocto:~$ voxl-mpa-to-ros
    bash: voxl-mpa-to-ros: command not found
    

    This would not be a big deal except for the fact that I would like to choose which services to publish to ros by providing a custom .launch file. I tried to use roslaunch with a custom .launch file
    and I got the following error:

    yocto:~$ roslaunch voxl_mpa_to_ros custom_voxl_mpa_to_ros.launch
    [custom_voxl_mpa_to_ros.launch] is neither a launch file in package [voxl_mpa_to_ros] nor is [voxl_mpa_to_ros] a launch file name
    The traceback for the exception was written to the log file
    

    How would I go about providing a custom launch file to choose which services to publish?


  • Dev Team

    Hi Cole,

    The voxl-mpa-to-ros command is actually an alias of that roslaunch command that you posted at the beginning that appears to have not made it into our standard bashrc (I'll add that in to a new version of voxl-utils).

    As for the custom launch file, I'd need a bit more information about the location/contents/etc in order to see why ros isn't happy.



  • We got it to work by just navigating to the launch file and invoking the roslaunch command from there (and excluding the package name): roslaunch voxl_mpa_to_ros.launch. Thanks, @Alex-Gardner!


Log in to reply