VOXL flight deck not connecting to QGC



  • Hello,
    I am not able to facilitate communication between VOXL and px4 so that I am able to access px4 through VOXL on QGC. I am able to connect to px4 separately using j1006 (blue connector) and can view all settings in QGC. I have configured wifi on the VOXL and set up IP addresses to access px4 over wifi. This worked in the past but since I upgraded the firmware of VOXL to 3.8 it no longer works. Please let me know what further information to provide to help solve this issue.


  • Dev Team

    Hi,

    In the latest release on voxl we've added the voxl-mavlink-server service to rout mavlink messages from vvpx4, it's possible that this service is not running. Can you show the output of voxl-inspect-services on your drone.



  • Hi,
    After inspecting services, this was the output. I can see the mavlink server is neither enabled nor running.

    voxl:/$ voxl-inspect-services 
     Service Name         |  Enabled  |   Running   |  CPU Usage
    ---------------------------------------------------------------
     docker-autorun       | Disabled  | Not Running |  
     docker-daemon        | Disabled  | Not Running |  
     modallink-relink     | Disabled  | Not Running |  
     voxl-camera-server   | Disabled  | Not Running |  
     voxl-cpu-monitor     | Disabled  | Not Running |  
     voxl-dfs-server      | Disabled  | Not Running |  
     voxl-imu-server      | Disabled  | Not Running |  
     voxl-mavlink-server  | Disabled  | Not Running |  
     voxl-modem           | Disabled  | Not Running |  
     voxl-portal          | Disabled  | Not Running |  
     voxl-qvio-server     | Disabled  | Not Running |  
     voxl-streamer        | Disabled  | Not Running |  
     voxl-tag-detector    | Disabled  | Not Running |  
     voxl-tflite-server   | Disabled  | Not Running |  
     voxl-time-sync       | Disabled  | Not Running |  
     voxl-vision-px4      |  Enabled  | Not Running |  
     voxl-wait-for-fs     |  Enabled  |  Completed  |
    

    I tried starting the service using systemctl and this was the output.

    voxl:/$ systemctl start voxl-mavlink-server
    voxl:/$ voxl-inspect-services 
     Service Name         |  Enabled  |   Running   |  CPU Usage
    ---------------------------------------------------------------
     docker-autorun       | Disabled  | Not Running |  
     docker-daemon        | Disabled  | Not Running |  
     modallink-relink     | Disabled  | Not Running |  
     voxl-camera-server   | Disabled  | Not Running |  
     voxl-cpu-monitor     | Disabled  | Not Running |  
     voxl-dfs-server      | Disabled  | Not Running |  
     voxl-imu-server      | Disabled  | Not Running |  
     voxl-mavlink-server  | Disabled  |   Running   |     0.0
     voxl-modem           | Disabled  | Not Running |  
     voxl-portal          | Disabled  | Not Running |  
     voxl-qvio-server     | Disabled  | Not Running |  
     voxl-streamer        | Disabled  | Not Running |  
     voxl-tag-detector    | Disabled  | Not Running |  
     voxl-tflite-server   | Disabled  | Not Running |  
     voxl-time-sync       | Disabled  | Not Running |  
     voxl-vision-px4      |  Enabled  | Not Running |  
     voxl-wait-for-fs     |  Enabled  |  Completed  |
    

    after configuring the voxl in softap mode, and connecting to it, the issue persists. Would downgrading the software release to VOXL Platform 3.6.0-0.5.0 help?
    Thanks


Log in to reply