voxl-mapper does not run: libgomp.so.1 does not exist



  • I install voxl-mapper without any issue:

    root@apq8096:~# opkg install voxl-mapper
    Installing voxl-mapper (0.0.6) on root.
    Configuring voxl-mapper.
    
    Done installing voxl-mapper
    

    But I cannot run it due to the following error:

    root@apq8096:~# voxl-mapper 
    voxl-mapper: error while loading shared libraries: libgomp.so.1: cannot open shared object file: No such file or directory
    

    I have not installed/removed any package before this.
    I have tried obtaining libgomp.so from here but could not install due to the absence of dpkg-deb. Even if I had dpkg-deb, I am not sure where I should install it so that the above error is resolved.
    My voxl version:

    root@apq8096:~# voxl-version
    --------------------------------------------------------------------------------
    system-image: 3.8.0
    kernel:       #1 SMP PREEMPT Tue Apr 26 18:08:39 UTC 2022 3.18.71-perf
    --------------------------------------------------------------------------------
    hw version:   VOXL
    --------------------------------------------------------------------------------
    voxl-suite:   0.7.0
    --------------------------------------------------------------------------------
    

    Running services:

    root@apq8096:~# voxl-inspect-services 
     Service Name         |  Enabled  |   Running   |  CPU Usage
    ---------------------------------------------------------------
     docker-autorun       | Disabled  | Not Running |  
     docker-daemon        | Disabled  | Not Running |  
     modallink-relink     | Disabled  | Not Running |  
     voxl-camera-server   |  Enabled  |   Running   |    17.3
     voxl-cpu-monitor     |  Enabled  |   Running   |     0.0
     voxl-dfs-server      | Disabled  | Not Running |  
     voxl-imu-server      |  Enabled  |   Running   |     0.0
     voxl-mavlink-server  |  Enabled  |   Running   |     0.0
     voxl-modem           | Disabled  | Not Running |  
     voxl-portal          |  Enabled  |   Running   |     0.0
     voxl-qvio-server     |  Enabled  |   Running   |     4.3
     voxl-streamer        | Disabled  | Not Running |  
     voxl-tag-detector    | Disabled  | Not Running |  
     voxl-tflite-server   | Disabled  | Not Running |  
     voxl-time-sync       | Disabled  | Not Running |  
     voxl-vision-px4      |  Enabled  |   Running   |     2.1
     voxl-wait-for-fs     |  Enabled  |  Completed  |  
    
    root@apq8096:~# cat /etc/opkg/opkg.conf                  
    ################################################################
    ## This file has been automatically generated.
    ## Please use voxl-configure-opkg to modify it.
    ################################################################
    dest root /
    option lists_dir /var/lib/opkg/lists
    arch all 1
    arch arm64 7
    
    src/gz modalai http://voxl-packages.modalai.com/dists/apq8096/stable/binary-arm64/
    

  • Dev Team

    Hi,

    You will need to install the openmp package for voxl which can be found here http://voxl-packages.modalai.com/stable/.

    The easiest way to do this would be to follow these steps:

    1. Edit the /etc/opkg/opkg.conf file and change the last line from src/gz modalai http://voxl-packages.modalai.com/dists/apq8096/stable/binary-arm64/ to src/gz modalai http://voxl-packages.modalai.com/stable/

    2. Run opkg update

    3. Run opkg install openmp

    4. Redit the /etc/opkg/opkg.conf file to change the last line back to the original i.e. src/gz modalai http://voxl-packages.modalai.com/dists/apq8096/stable/binary-arm64/

    5. Rerun opkg update

    Let me know if there are any issues.


Log in to reply