docker load -i roskinetic-xenial-opencv.tar gives no such file or directory error

  • I'm trying to build a customized version of the roskinetic docker image mentioned in the docs. I added opencv, cv_bridge, and other misc dependencies to the roskinetic-xenial docker image by installing them with apt inside the image, committing the changes to a new image (roskinetic-xenial:opencv), running docker save roskinetic-xenial:opencv > roskinetic-xenial-opencv.tar, and running adb push roskinetic-xenial-opencv /data/. I get this error when I run docker load -i roskinetic-xenial-opencv.tar inside /data/:

    Error response from daemon: open /data/tmp/docker-import-737782374/repo/a36ddef81cb09cd9fa7749e7d29fe7ff252301cb330d369f05648c681e726448/layer.tar: no such file or directory.

    I tried deleting the contents of /data/tmp and restarting VOXL to no avail. I was able to get the original roskinetic-xenial:v1.0 docker image running following the docs linked above, but for some reason, this customized docker image isn't loading.

  • Actually, using docker import fixed it, nvm!

Log in to reply