# docker on voxl flight deck stop working

Source: https://forum.modalai.com/topic/1435/docker-on-voxl-flight-deck-stop-working
Category: General Questions (https://forum.modalai.com/category/2/general-questions)
Posted: 2022-10-09 04:12:09 UTC by Dong Liu
Replies: 2 · Views: 658

## Dong Liu · 2022-10-09 04:12:09 UTC

Hi,

Docker suddenly stops working on my voxl flight deck. The docker daemon won't start.

Here is the error message

voxl:/$ systemctl status docker-daemon  -l
Oct 09 03:45:44 apq8096 docker[4238]: time="2022-10-09T03:45:44.540007000Z" level=warning msg="Could not delete local endpoint clever_babbage during endpoint cleanup: endpoint with name clever_babbage id c039c8337246d161b9242a1a51e1c700b934fd54b4de97e1b2f286b2ae8782d7 has active containers"
Oct 09 03:45:44 apq8096 docker[4238]: time="2022-10-09T03:45:44.548364000Z" level=fatal msg="Error starting daemon: Error initializing network controller: could not delete the default bridge network: network bridge has active endpoints"
Oct 09 03:45:44 apq8096 systemd[1]: docker-daemon.service: Main process exited, code=exited, status=1/FAILURE

I googled this error. Many people suggested that rm -r /var/lib/docker/network should fix it. But it didn't work. Everytime I tried to start the docker daemon, a new socket file was created under /var/lib/docker/network/files

Thanks!

Dong

## Reply by Dong Liu · 2022-10-09 14:27:47 UTC

If I want to reset docker to the initial state. What should I do?

Will
rm -r /data/containers
rm -r /data/overlays
rm -r /var/lib/docker

do it?

Thanks!

## Reply by Dong Liu · 2022-10-09 20:42:15 UTC

after mkdir /data/docker and /usr/bin/docker daemon -g /data/docker, I saw there is file /data/docker/network/files/local-kv.db. So I just rm /data/network/files/local-kv.db. Now the docker daemon will start.

But anyway I think it is better make change in /etc/systemd/system/docker-daemon.service, from

ExecStart=/usr/bin/docker daemon -g /data

to

ExecStart=/usr/bin/docker daemon -g /data/docker

So next time if we want to remove all docker images and clean up the docker, just remove everything under /data/docker.
